Supported browsers

SLP Toolkit is officially supported with the latest versions of:

  • Chrome for Mac and Windows
  • Safari for Mac
  • Safari for iOS
  • Firefox for Mac and Windows  
  • Microsoft Edge for Windows

 

Other system requirements

SLP Toolkit will run on most systems, but the following things are needed for a good user experience:

  • Tablet, laptop, or desktop computer (the image viewer will work on your favorite phones, though!)
  • Display resolution of 1024x768 or higher
  • 4GB Ram
     

Unsupported browsers

Developer or Beta versions of supported browsers are never tested, so it's best to avoid these when using SLP Toolkit. Versions of browsers that are older than the most recent may not work properly with all features. Please update to the latest version of your favorite browser to ensure the best experience (check it here).

We'd love for SLP Toolkit to work in every situation, so please get in touch (email support@slptookit.com) if you are experiencing a problem.

 

Why don't we support all browsers?

SLP Toolkit is a modern web application that uses some of the newest capabilities of HTML5, CSS3, and JavaScript. Different browsers still interpret these in different ways. These differences could potentially cause problems, so it's in your best interest to stick with mainstream browsers and keep them up to date!

That being said, we try and design our applications so that unsupported browser functionality degrades gracefully :)